Suche
Suche Menü

Excel: SUMMEWENNS mit Datumsbereich

Letzhin musste ich im Excel die Summe aller Beträge auf die einzelnen Monate des Jahres aufteilen. Mit der Formel SUMMEWENN können Summen mit einer einzelnen Bedingung z.B. einer Kategorie umgesetzt werden.
Brauchen wir nun die Summe aller Beträge des Monats Januar, kommen wir mit SUMMEWENNS ans Ziel, welche aus mehreren Bedingungen aus einer «Nebenzelle» bestehen kann:

=SUMMEWENNS(B:B;A:A;">=" & DATUM(2020;1;1);A:A;"<=" & DATUM(2020;1;30))

Somit summieren wir alle Werte der Spalte B, deren „Nebenzelle“ in A größer gleich ist als der 1.1.2020 UND kleiner gleich dem 30.1.2020.

Beim kopieren der Formel ins Excel müssen allenfalls die Anführungszeichen in der Formel neu geschrieben werden.

Anstelle eines fixen Datums kann auch der Verzweis zu einer Zelle verwendet werden:

=SUMMEWENNS(B:B;A:A;">=" &D3;A:A;"<=" &E3)

In diesem Beispiel ist das Startdatum in der Zelle D3 und das Enddatum in der Zelle E3.

Es können auch weitere Kriterien hinzugefügt werden. So können z.B. auch nur Datensätze gezählt werden welche innerhalb eines Datumsbereichs liegen und einem weiteren Kriterium entsprechen:

=SUMMEWENNS(C:C;A:A;">="&DATUM(2022;1;1);A:A;"<="&DATUM(2022;12;31);B:B;"="&"Lebensmittel")

In diesem Beispiel muss der Datumsbereich innerhalb des Jahres 2022 liegen sowie dem Kriterium «Lebensmittel» entsprechen.

7 Kommentare Schreibe einen Kommentar

  1. Danke dafür. Bin grade beim Erstellen eines Haushaltsbuch mit Dashboard für die Auswertung von Fixkosten und flexiblen Ausgaben und deren prozentualen Anteilen. Und Ihre Lösung ist extrem elegant 🙂

    Antworten

  2. Wie sieht die Formel aus, wenn ich statt der Datumswerte einen Zellbezug eingeben moechte, um so immervariable Daten von bis zu erhalten

    Antworten

    • Danke für die gute Frage. Ich habe den Blog-Artikel entsprechend angepasst. Will man das Datum dynamisch aus einer Zelle beziehen, so kann anstelle der Datum() Funktion einfach der Name der Zelle angegeben werden.

      Antworten

  3. Hi, wie sieht die Formel aus, wenn man mit sowohl nach einem Schlüsselwort zB «Lebensmittel» und nach einem Datumsbereich (zwischen expliziten Zellen) suchen möchte?

    Antworten

    • Das kann einfach erweitert werden:
      =SUMMEWENNS(C:C;A:A;»>=»&DATUM(2022;1;1);A:A;»<="&DATUM(2022;12;31);B:B;"="&"Lebensmittel") Ich habe das Beispiel im Beitrag ergänzt.

      Antworten

  4. Guten Tag zusammen,
    ich habe die im Nachgang folgende Formel aufgrund ihres letztewn Kommentars vom 15.07.22 konsturiert. Leider habe ich zwei Probleme. Lasse ich die Tabelle aus der die Daten kommen geschlossen und öffne ich die Tabelle in der die Formel steht bekomme ich Wert angezeigt. Öffne ich beide Tabellen ist das Formelergebnis 0 obwohl die Kriterien Prüfungen wahr ergeben. Könnten sie mir hier vielleicht weiterhelfen? Ich verzweifle. Schöne Grüße Wilfried Dircks

    =WENN(UND($A$4=»»;$C$4=»»);»»;SUMMEWENNS(‹X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$K$6:$K$1607;’X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$B$6:$B$1607;$A$4=6021;’X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$D$6:$D$1607;$C$4>=DATUM(2022;1;1);’X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$E$6:$E$1607;$D$4<=DATUM(2022;12;31)))

    Antworten

    • Guten Tag Herr Dircks
      Sie haben eine interessante Feststellung gemacht. Ich kenne das Problem eher umgekehrt: https://www.youtube.com/watch?v=dE1cblEXT6U. Bei geschlossenen Dateien werden die Werte nicht übernommen.
      Probieren Sie mal die jeweiligen Zellen aus denen Sie die Daten holen zu benennen. Wahrscheinlich wird dies das Problem lösen.

      Antworten

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.