Suche
Suche Menü

Excel: SUMMEWENNS mit Datumsbereich

Letzhin musste ich im Excel die Summe aller Beträge auf die einzelnen Monate des Jahres aufteilen. Mit der Formel SUMMEWENN können Summen mit einer einzelnen Bedingung z.B. einer Kategorie umgesetzt werden.
Brauchen wir nun die Summe aller Beträge des Monats Januar, kommen wir mit SUMMEWENNS ans Ziel, welche aus mehreren Bedingungen aus einer «Nebenzelle» bestehen kann:

=SUMMEWENNS(B:B;A:A;">=" & DATUM(2020;1;1);A:A;"<=" & DATUM(2020;1;30))

Somit summieren wir alle Werte der Spalte B, deren „Nebenzelle“ in A größer gleich ist als der 1.1.2020 UND kleiner gleich dem 30.1.2020.

Beim kopieren der Formel ins Excel müssen allenfalls die Anführungszeichen in der Formel neu geschrieben werden.

Anstelle eines fixen Datums kann auch der Verzweis zu einer Zelle verwendet werden:

=SUMMEWENNS(B:B;A:A;">=" &D3;A:A;"<=" &E3)

In diesem Beispiel ist das Startdatum in der Zelle D3 und das Enddatum in der Zelle E3.

Es können auch weitere Kriterien hinzugefügt werden. So können z.B. auch nur Datensätze gezählt werden welche innerhalb eines Datumsbereichs liegen und einem weiteren Kriterium entsprechen:

=SUMMEWENNS(C:C;A:A;">="&DATUM(2022;1;1);A:A;"<="&DATUM(2022;12;31);B:B;"="&"Lebensmittel")

In diesem Beispiel muss der Datumsbereich innerhalb des Jahres 2022 liegen sowie dem Kriterium «Lebensmittel» entsprechen.

Wichtig: Das Feld in welchem das Datum steht, muss auch als Datum formatiert sein. Ich habe auch schon Beispiele gesehen in denen '01.01.2022 stand. Das Datum hatte in Hochkomma vorgesetzt. Damit funktioniert es natürlich nicht, da ein solches Datum ungültig ist.

10 Kommentare Schreibe einen Kommentar

  1. Danke dafür. Bin grade beim Erstellen eines Haushaltsbuch mit Dashboard für die Auswertung von Fixkosten und flexiblen Ausgaben und deren prozentualen Anteilen. Und Ihre Lösung ist extrem elegant 🙂

    Antworten

  2. Wie sieht die Formel aus, wenn ich statt der Datumswerte einen Zellbezug eingeben moechte, um so immervariable Daten von bis zu erhalten

    Antworten

    • Danke für die gute Frage. Ich habe den Blog-Artikel entsprechend angepasst. Will man das Datum dynamisch aus einer Zelle beziehen, so kann anstelle der Datum() Funktion einfach der Name der Zelle angegeben werden.

      Antworten

  3. Hi, wie sieht die Formel aus, wenn man mit sowohl nach einem Schlüsselwort zB «Lebensmittel» und nach einem Datumsbereich (zwischen expliziten Zellen) suchen möchte?

    Antworten

    • Das kann einfach erweitert werden:
      =SUMMEWENNS(C:C;A:A;»>=»&DATUM(2022;1;1);A:A;»<="&DATUM(2022;12;31);B:B;"="&"Lebensmittel") Ich habe das Beispiel im Beitrag ergänzt.

      Antworten

  4. Guten Tag zusammen,
    ich habe die im Nachgang folgende Formel aufgrund ihres letztewn Kommentars vom 15.07.22 konsturiert. Leider habe ich zwei Probleme. Lasse ich die Tabelle aus der die Daten kommen geschlossen und öffne ich die Tabelle in der die Formel steht bekomme ich Wert angezeigt. Öffne ich beide Tabellen ist das Formelergebnis 0 obwohl die Kriterien Prüfungen wahr ergeben. Könnten sie mir hier vielleicht weiterhelfen? Ich verzweifle. Schöne Grüße Wilfried Dircks

    =WENN(UND($A$4=»»;$C$4=»»);»»;SUMMEWENNS(‹X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$K$6:$K$1607;’X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$B$6:$B$1607;$A$4=6021;’X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$D$6:$D$1607;$C$4>=DATUM(2022;1;1);’X:\Kalk 22\Fahrzeug-Plan-Kosten\[Jahres-Steuern-Abrech.xlsx]VST.›!$E$6:$E$1607;$D$4<=DATUM(2022;12;31)))

    Antworten

    • Guten Tag Herr Dircks
      Sie haben eine interessante Feststellung gemacht. Ich kenne das Problem eher umgekehrt: https://www.youtube.com/watch?v=dE1cblEXT6U. Bei geschlossenen Dateien werden die Werte nicht übernommen.
      Probieren Sie mal die jeweiligen Zellen aus denen Sie die Daten holen zu benennen. Wahrscheinlich wird dies das Problem lösen.

      Antworten

  5. Hallo Herr Blatter,
    danke für diese Beitrag. Ich denke es verstanden zu haben, allerdings zeigt sich bei immer wieder nur die Null als Ergebnis.

    Zunächst dachte ich es liegt daran, dass ich die Formel nicht einfach mit OpenLibre Calc übernehmen kann. Denn damit arbeite ich.
    Doch mit MS Excell: Ebenfalls eine Null.

    Dann habe ich ein wenig mit den Datums-Formatierungen herum gespielt.
    Ebenfalls ohne die erwartete Summe.

    Sie verwenden in Ihrem Beispiel die Formatierung «JJJJ:M:T»
    → 2022;1;1

    Ebenso gut könnte man ja auch «2022;01;01» angeben.

    Wie dem auch sei: Auch wenn ich das Gebietsschema auf bspw. engl/amerikanisch umstelle, kann ich diese Formatierung nicht wählen.

    Warum nicht «TT.MM.JJJJ» ?

    Egal wie ich es drehe und wende.
    Das Datum in der Spalte entsprechend vorbereite usw.
    Es kommt immer die Null.

    Bei mir habe ich ein weiteres Kriterien hinzugefügt. Für die Buchhaltung sollen Datensätze gezählt werden, welche innerhalb eines Datumsbereichs liegen und einer bestimmten Kontonummer (Porto, Miete usw.) entsprechen.

    =SUMMEWENNS(U:U;F:F;»>=»&DATUM(2022;1;1);F:F;»<="&DATUM(2022;12;31);G:G;"=="&"4925")

    U = Betrag
    G = Kontonummer
    F = Buchungsdatum

    Antworten

    • Guten Tag STEPHAN
      Der Fehler liegt in der Formel. Sie nutzen ein == am Schluss. Es darf aber nur ein = stehen.
      Mit dieser Anpassung funktioniert die Formel. (Getestet mit LibreOffice unter Linux und Excel mit Mac)

      Antworten

      • Hallo Herr Blatter,

        herzlichen Dank für die Rückmeldung.
        Jetzt funktioniert es 🙂

        Das «==» war einer meiner unzähligen Versuche. Vielleicht sollte ich demnächst eine Tabelle für solche try and error Expeditionen erstellen, um noch den Überblick zu behalten …

        Und es funktionert so auch mit Verweis zu einer Zelle:
        =SUMMEWENNS(U:U;F:F;»>=»&DATUM(2022;5;1);F:F;»<="&DATUM(2022;5;31);G:G;"="&H202)

        Läuft sowohl mit "LibreOffice Calc" unter Win als auch unter Linux.

        Die ODS Datei läuft außerdem unter "Open Office Calc".

        Excel unter Win haut mir allerdings die Formel raus; was aber daran liegen könnte, dass es eine ODS Datei ist. Nur in XLS konvertieren genügt nicht. Wenn ich die Datei zuvor als XLS (2003) abspeichere und dann in Excel öffne, dann zeigt Excel mir den Fehler "=#NV" an. Als XLSX (also Excel 2007-365) funktioniert es dann. Ich schichte allerdings sowieso seit geraumer Zeit auf Linux um.

        Vielen Dank für Ihre Unterstützung

        Antworten

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.